[PATCH v4a 03/38] clocksource/drivers/arm_arch_timer: Do not use timer namespace for timer_shutdown() function

Marc Zyngier maz at kernel.org
Sat Nov 5 02:38:10 PDT 2022


On 2022-11-05 06:00, Steven Rostedt wrote:
> From: "Steven Rostedt (Google)" <rostedt at goodmis.org>
> 
> A new "shutdown" timer state is being added to the generic timer code. 
> One
> of the functions to change the timer into the state is called
> "timer_shutdown()". This means that there can not be other functions
> called "timer_shutdown()" as the timer code owns the "timer_*" name 
> space.
> 
> Rename timer_shutdown() to clk_timer_shutdown() to avoid this conflict.
> 

bikeshed: s/clk_timer/arch_timer/ would make the naming consistent
with the rest of the code.

Thanks,

          M.

> Cc: Mark Rutland <mark.rutland at arm.com>
> Cc: Marc Zyngier <maz at kernel.org>
> Cc: Daniel Lezcano <daniel.lezcano at linaro.org>
> Cc: Thomas Gleixner <tglx at linutronix.de>
> Cc: linux-arm-kernel at lists.infradead.org
> Signed-off-by: Steven Rostedt (Google) <rostedt at goodmis.org>
> ---
>  drivers/clocksource/arm_arch_timer.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/clocksource/arm_arch_timer.c
> b/drivers/clocksource/arm_arch_timer.c
> index a7ff77550e17..c36042d6a2f8 100644
> --- a/drivers/clocksource/arm_arch_timer.c
> +++ b/drivers/clocksource/arm_arch_timer.c
> @@ -687,8 +687,8 @@ static irqreturn_t arch_timer_handler_virt_mem(int
> irq, void *dev_id)
>  	return timer_handler(ARCH_TIMER_MEM_VIRT_ACCESS, evt);
>  }
> 
> -static __always_inline int timer_shutdown(const int access,
> -					  struct clock_event_device *clk)
> +static __always_inline int clk_timer_shutdown(const int access,
> +					      struct clock_event_device *clk)
>  {
>  	unsigned long ctrl;
> 
> @@ -701,22 +701,22 @@ static __always_inline int timer_shutdown(const
> int access,
> 
>  static int arch_timer_shutdown_virt(struct clock_event_device *clk)
>  {
> -	return timer_shutdown(ARCH_TIMER_VIRT_ACCESS, clk);
> +	return clk_timer_shutdown(ARCH_TIMER_VIRT_ACCESS, clk);
>  }
> 
>  static int arch_timer_shutdown_phys(struct clock_event_device *clk)
>  {
> -	return timer_shutdown(ARCH_TIMER_PHYS_ACCESS, clk);
> +	return clk_timer_shutdown(ARCH_TIMER_PHYS_ACCESS, clk);
>  }
> 
>  static int arch_timer_shutdown_virt_mem(struct clock_event_device 
> *clk)
>  {
> -	return timer_shutdown(ARCH_TIMER_MEM_VIRT_ACCESS, clk);
> +	return clk_timer_shutdown(ARCH_TIMER_MEM_VIRT_ACCESS, clk);
>  }
> 
>  static int arch_timer_shutdown_phys_mem(struct clock_event_device 
> *clk)
>  {
> -	return timer_shutdown(ARCH_TIMER_MEM_PHYS_ACCESS, clk);
> +	return clk_timer_shutdown(ARCH_TIMER_MEM_PHYS_ACCESS, clk);
>  }
> 
>  static __always_inline void set_next_event(const int access, unsigned 
> long evt,

-- 
Jazz is not dead. It just smells funny...



More information about the linux-arm-kernel mailing list