[PATCH 5/9] soc: apple: Add RTKit IPC library

Robin Murphy robin.murphy at arm.com
Tue Mar 22 10:41:11 PDT 2022


On 2022-03-22 13:13, Arnd Bergmann wrote:
>> +#define rtk_err(format, arg...) dev_err(rtk->dev, "RTKit: " format, ##arg)
>> +#define rtk_warn(format, arg...) dev_warn(rtk->dev, "RTKit: " format, ##arg)
>> +#define rtk_info(format, arg...) dev_info(rtk->dev, "RTKit: " format, ##arg)
>> +#define rtk_dbg(format, arg...) dev_dbg(rtk->dev, "RTKit: " format, ##arg)
> 
> I generally don't like the custom printing macros, please just open-code
> the prints where they are used, that makes it easier for other kernel
> developers to see exactly what is being printed

More to the point, implicitly depending on having something named "rtk" 
in scope is pretty much inexcusable, and the only thing left after 
fixing that is what we have pr_fmt for ;)

Robin.



More information about the linux-arm-kernel mailing list