[PATCH v4 3/9] gpu: host1x: Add context device management code

Dmitry Osipenko digetx at gmail.com
Sat Mar 12 10:12:31 PST 2022


01.03.2022 19:14, cyndis at kapsi.fi пишет:
> +/* host1x context devices */
> +
> +struct host1x_context {
> +	struct host1x *host;
> +
> +	refcount_t ref;
> +	struct pid *owner;
> +
> +	struct device dev;
> +	u64 dma_mask;
> +	u32 stream_id;
> +};

I'm still not very happy about the "context" names. For example here
it's only about the "memory context", then why not to name struct as
host1x_memory_context or host1x_memctx?

It's not good to use generic names for a special things, it hurts
readability of the code. It's important to choose good names.



More information about the linux-arm-kernel mailing list