[PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible

Francesco Dolcini francesco.dolcini at toradex.com
Tue Jul 12 09:33:40 PDT 2022


Hi all,
This series update the STMPE MFD driver to use of_compatible to probe for
sub-functions instead of using hardcoded names.  Matching by name does not seems
in general a good idea, in this specific case it is even worst since the node
name are not compliant to the current naming convention (they are not generic
and they do include underscores), and because of that recently
we had a regression introduced [1].

This change was suggested by Ahmad Fatoum [2].

[1] commit 56086b5e ("ARM: dts: imx6qdl-apalis: Avoid underscore in node name")
[2] https://lore.kernel.org/all/86815346-209e-304e-3565-b4160afa48e8@pengutronix.de/

Changes in v2:
 - split in a separate patch the removal of rotator from probe
 - remove define usage for compatible strings

Francesco Dolcini (5):
  mfd: stmpe: Remove rotator block from probe
  mfd: stmpe: Probe sub-function by compatible
  dt-bindings: gpio: stmpe: Remove node name requirement
  dt-bindings: iio: adc: stmpe: Remove node name requirement
  dt-bindings: input: touchscreen: stmpe: Remove node name requirement

 .../devicetree/bindings/gpio/gpio-stmpe.txt         |  3 +--
 .../devicetree/bindings/iio/adc/st,stmpe-adc.yaml   |  3 +--
 .../devicetree/bindings/input/touchscreen/stmpe.txt |  3 +--
 drivers/mfd/stmpe.c                                 | 13 +++++--------
 4 files changed, 8 insertions(+), 14 deletions(-)

-- 
2.25.1




More information about the linux-arm-kernel mailing list