[PATCH v2 06/28] arm64/sysreg: Add _EL1 into ID_AA64PFR0_EL1 definition names

Kristina Martsenko kristina.martsenko at arm.com
Wed Aug 17 08:44:09 PDT 2022


On 15/08/2022 17:26, Mark Brown wrote:
> Normally we include the full register name in the defines for fields within
> registers but this has not been followed for ID registers. In preparation
> for automatic generation of defines add the _EL1s into the defines for
> ID_AA64PFR0_EL1 to follow the convention. No functional changes.
> 
> Signed-off-by: Mark Brown <broonie at kernel.org>
> ---

> diff --git a/arch/arm64/include/asm/cpufeature.h b/arch/arm64/include/asm/cpufeature.h
> index 868307aff3b0..edddf353bc71 100644
> --- a/arch/arm64/include/asm/cpufeature.h
> +++ b/arch/arm64/include/asm/cpufeature.h
> @@ -603,21 +603,21 @@ static inline bool id_aa64mmfr0_mixed_endian_el0(u64 mmfr0)
>  
>  static inline bool id_aa64pfr0_32bit_el1(u64 pfr0)
>  {
> -	u32 val = cpuid_feature_extract_unsigned_field(pfr0, ID_AA64PFR0_EL1_SHIFT);
> +	u32 val = cpuid_feature_extract_unsigned_field(pfr0, ID_AA64PFR0_EL1_EL0_SHIFT);

s/EL1_EL0/EL1_EL1/ ?



More information about the linux-arm-kernel mailing list