[PATCH 04/15] irq: simplify handle_domain_{irq,nmi}()

Mark Rutland mark.rutland at arm.com
Fri Oct 22 08:05:55 PDT 2021


On Fri, Oct 22, 2021 at 11:52:28AM +0100, Marc Zyngier wrote:
> On Thu, 21 Oct 2021 19:02:25 +0100,
> Mark Rutland <mark.rutland at arm.com> wrote:
> > 
> > There's no need for handle_domain_{irq,nmi}() to open-code the NULL
> > check performed by handle_irq_desc(), nor the resolution of the desc
> > performed by generic_handle_domain_irq().
> > 
> > Use generic_handle_domain_irq() directly, as this is functioanlly
> > equivalent and clearer. At the same time, delete the stale comments,
> > which are no longer helpful.
> > 
> > There should be no functional change as a result of this patch.
> > 
> > Signed-off-by: Mark Rutland <mark.rutland at arm.com>
> > Cc: Marc Zyngier <maz at kernel.org>
> > Cc: Thomas Gleixner <tglx at linutronix.de>
> > ---
> >  kernel/irq/irqdesc.c | 24 ++++--------------------
> >  1 file changed, 4 insertions(+), 20 deletions(-)

> Yup, that's really neat. I somehow missed that when I moved some of
> the legacy stuff to be ARM specific.
> 
> On a vaguely related note, I think you can drop the EXPORT_SYMBOL_GPL
> on handle_irq_desc() now.

Seems so:

[mark at lakrids:~/src/linux]% git grep -w handle_irq_desc   
arch/arm/kernel/irq.c:          handle_irq_desc(desc);
include/linux/irqdesc.h:int handle_irq_desc(struct irq_desc *desc);
kernel/irq/irqdesc.c:int handle_irq_desc(struct irq_desc *desc)
kernel/irq/irqdesc.c:   return handle_irq_desc(irq_to_desc(irq));
kernel/irq/irqdesc.c:   return handle_irq_desc(irq_resolve_mapping(domain, hwirq));

I'll add a patch to clean that up.

Thanks,
Mark



More information about the linux-arm-kernel mailing list