[PATCH v2 09/13] arm64: extable: use `ex` for `exception_table_entry`
Mark Rutland
mark.rutland at arm.com
Tue Oct 19 09:02:15 PDT 2021
Subsequent patches will extend `struct exception_table_entry` with more
fields, and the distinction between the entry and its `fixup` field will
become more important.
For clarity, let's consistently use `ex` to refer to refer to an entire
entry. In subsequent patches we'll use `fixup` to refer to the fixup
field specifically. This matches the naming convention used today in
arch/arm64/net/bpf_jit_comp.c.
There should be no functional change as a result of this patch.
Signed-off-by: Mark Rutland <mark.rutland at arm.com>
Acked-by: Robin Murphy <robin.murphy at arm.com>
Reviewed-by: Ard Biesheuvel <ardb at kernel.org>
Cc: Catalin Marinas <catalin.marinas at arm.com>
Cc: James Morse <james.morse at arm.com>
Cc: Will Deacon <will at kernel.org>
---
arch/arm64/mm/extable.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/arch/arm64/mm/extable.c b/arch/arm64/mm/extable.c
index 3ebc738870f5..dba3d59f3eca 100644
--- a/arch/arm64/mm/extable.c
+++ b/arch/arm64/mm/extable.c
@@ -8,15 +8,15 @@
bool fixup_exception(struct pt_regs *regs)
{
- const struct exception_table_entry *fixup;
+ const struct exception_table_entry *ex;
- fixup = search_exception_tables(instruction_pointer(regs));
- if (!fixup)
+ ex = search_exception_tables(instruction_pointer(regs));
+ if (!ex)
return false;
if (in_bpf_jit(regs))
- return arm64_bpf_fixup_exception(fixup, regs);
+ return arm64_bpf_fixup_exception(ex, regs);
- regs->pc = (unsigned long)&fixup->fixup + fixup->fixup;
+ regs->pc = (unsigned long)&ex->fixup + ex->fixup;
return true;
}
--
2.11.0
More information about the linux-arm-kernel
mailing list