[RFC net-next 1/6] ethernet: add a helper for assigning port addresses
Jakub Kicinski
kuba at kernel.org
Fri Oct 15 15:30:53 PDT 2021
On Fri, 15 Oct 2021 14:36:00 -0700 Shannon Nelson wrote:
> On 10/15/21 12:38 PM, Jakub Kicinski wrote:
> > We have 5 drivers which offset base MAC addr by port id.
> > Create a helper for them.
> >
> > This helper takes care of overflows, which some drivers
> > did not do, please complain if that's going to break
> > anything!
> > +/**
> > + * eth_hw_addr_set_port - Generate and assign Ethernet address to a port
> > + * @dev: pointer to port's net_device structure
> > + * @base_addr: base Ethernet address
> > + * @id: offset to add to the base address
> > + *
> > + * Assign a MAC address to the net_device using a base address and an offset.
> > + * Commonly used by switch drivers which need to compute addresses for all
> > + * their ports. addr_assign_type is not changed.
> > + */
> > +static inline void eth_hw_addr_set_port(struct net_device *dev,
> > + const u8 *base_addr, u8 id)
>
> To me, the words "_set_port" imply that you're going to force "id" into
> the byte, overwriting what is already there. Since this instead is
> adding "id" to the byte, perhaps a better name would include the word
> "offset", maybe like eth_hw_addr_set_port_offset(), to better imply the
> actual operation.
>
> Personally, I think my name suggestion is too long, but it gets my
> thought across.
I started with eth_hw_addr_set_offset() my thought process was:
.._set_offset() sounds like it's setting the offset
dev_addr_mod() uses offset to modify just part of the address
so we have two similar functions using 'offset' with different
meaning
how about we name it after the most common use? -> .._port()
Thinking again maybe eth_hw_addr_gen()? We "generate" a port address
based on base address and port ID.
I can change if others agree that .._set_offset() is better.
More information about the linux-arm-kernel
mailing list