[PATCH] ARM: Qualify enabling of swiotlb_init()
Christoph Hellwig
hch at lst.de
Fri Mar 19 13:07:31 GMT 2021
On Thu, Mar 18, 2021 at 09:03:33PM -0700, Florian Fainelli wrote:
> #ifdef CONFIG_ARM_LPAE
> + if (swiotlb_force == SWIOTLB_FORCE ||
> + max_pfn > arm_dma_pfn_limit)
Does arm_dma_pfn_limit do the right thing even with the weirdest
remapping ranges? Maybe a commen here would be useful.
> + swiotlb_init(1);
> + else
> + swiotlb_force = SWIOTLB_NO_FORCE;
Konrad: what do you think of setting swiotlb_force to SWIOTLB_NO_FORCE
and only switching it to SWIOTLB_NORMAL when swiotlb_init* is called?
That kind makes more sense than forcing the callers to do it.
While we're at it, I think swiotlb_force should probably be renamed to
swiotlb_mode or somethng like that.
More information about the linux-arm-kernel
mailing list