[PATCH] arm64: cpufeature: Use defined macro instead of magic numbers

Will Deacon will at kernel.org
Thu Jul 15 09:31:25 PDT 2021


On Wed, Jul 14, 2021 at 02:13:03PM +0800, Shaokun Zhang wrote:
> Macro 'CLIDR_LOUU_SHIFT' and 'CLIDR_LOUIS_SHIFT' are defined, so use
> these to replace the magic numbers.
> 
> Cc: Catalin Marinas <catalin.marinas at arm.com>
> Cc: Will Deacon <will at kernel.org>
> Cc: Marc Zyngier <maz at kernel.org>
> Signed-off-by: Shaokun Zhang <zhangshaokun at hisilicon.com>
> ---
>  arch/arm64/kernel/cpufeature.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/arch/arm64/kernel/cpufeature.c b/arch/arm64/kernel/cpufeature.c
> index 125d5c9471ac..4ee3496bcff8 100644
> --- a/arch/arm64/kernel/cpufeature.c
> +++ b/arch/arm64/kernel/cpufeature.c
> @@ -1733,7 +1733,7 @@ static void cpu_has_fwb(const struct arm64_cpu_capabilities *__unused)
>  	u64 val = read_sysreg_s(SYS_CLIDR_EL1);
>  
>  	/* Check that CLIDR_EL1.LOU{U,IS} are both 0 */
> -	WARN_ON(val & (7 << 27 | 7 << 21));
> +	WARN_ON(val & (7 << CLIDR_LOUU_SHIFT | 7 << CLIDR_LOUIS_SHIFT));
>  }

I think this would be even better as:

	WARN_ON(CLIDR_LOUU(val) || CLIDR_LOUIS(val));

Will



More information about the linux-arm-kernel mailing list