[PATCH v8 12/22] counter: Rename counter_count_function to counter_function

David Lechner david at lechnology.com
Sat Feb 20 11:56:13 EST 2021

On 2/14/21 11:13 AM, Jonathan Cameron wrote:
> On Fri, 12 Feb 2021 21:13:36 +0900
> William Breathitt Gray <vilhelm.gray at gmail.com> wrote:
>> The phrase "Counter Count function" is verbose and unintentionally
>> implies that function is a Count extension. This patch adjusts the
>> Counter subsystem code to use the more direct "Counter function" phrase
>> to make the intent of this code clearer. The phrase "Count action" is
>> adjusted herein as well for the same reason.
>> Cc: Syed Nayyar Waris <syednwaris at gmail.com>
>> Cc: Patrick Havelange <patrick.havelange at essensium.com>
>> Cc: Kamel Bouhara <kamel.bouhara at bootlin.com>
>> Cc: Fabrice Gasnier <fabrice.gasnier at st.com>
>> Cc: Maxime Coquelin <mcoquelin.stm32 at gmail.com>
>> Cc: Alexandre Torgue <alexandre.torgue at st.com>
>> Cc: David Lechner <david at lechnology.com>
>> Signed-off-by: William Breathitt Gray <vilhelm.gray at gmail.com>
> I agree this makes sense in the counter core code, but in the drivers
> it may not be quite so obvious we are talking about a counter function
> given some of the bits of hardware do a number of other things.
> I guess up to the various driver maintainers on whether they
> think the new meaning is clear enough!
> Jonathan

TBH, I think "counter count function" makes more sense to me.

More information about the linux-arm-kernel mailing list