[PATCH v18 02/11] arm64: Rename kexec elf_headers_mem to elf_load_addr

Thiago Jung Bauermann bauerman at linux.ibm.com
Mon Feb 15 16:34:02 EST 2021

Lakshmi Ramasubramanian <nramas at linux.microsoft.com> writes:

> The architecture specific field, elf_headers_mem in struct kimage_arch,
> that holds the address of the buffer in memory for ELF core header for
> arm64 has a different name than the one used for powerpc.  This makes
> it hard to have a common code for setting up the device tree for
> kexec system call.
> Rename elf_headers_mem to elf_load_addr to align with powerpc name so
> common code can use it.
> Signed-off-by: Lakshmi Ramasubramanian <nramas at linux.microsoft.com>
> Suggested-by: Thiago Jung Bauermann <bauerman at linux.ibm.com>
> ---
>  arch/arm64/include/asm/kexec.h         | 2 +-
>  arch/arm64/kernel/machine_kexec_file.c | 6 +++---
>  2 files changed, 4 insertions(+), 4 deletions(-)

Reviewed-by: Thiago Jung Bauermann <bauerman at linux.ibm.com>

Thiago Jung Bauermann
IBM Linux Technology Center

More information about the linux-arm-kernel mailing list