[RESEND PATCH v4] ACPI: Move sdei_init and ghes_init ahead to handle platform errors earlier

Bjorn Helgaas helgaas at kernel.org
Tue Dec 21 15:17:01 PST 2021


On Thu, Dec 16, 2021 at 09:34:56PM +0800, Shuai Xue wrote:
> On an ACPI system, ACPI is initialised very early from a subsys_initcall(),
> while SDEI is not ready until a subsys_initcall_sync().
> 
> The SDEI driver provides functions (e.g. apei_sdei_register_ghes,
> apei_sdei_unregister_ghes) to register or unregister event callback for
> dispatcher in firmware. When the GHES driver probing, it registers the
> corresponding callback according to the notification type specified by
> GHES. If the GHES notification type is SDEI, the GHES driver will call
> apei_sdei_register_ghes to register event call.
>
> When the firmware emits an event, it migrates the handling of the event
> into the kernel at the registered entry-point __sdei_asm_handler. And
> finally, the kernel will call the registered event callback and return
> status_code to indicate the status of event handling. SDEI_EV_FAILED
> indicates that the kernel failed to handle the event.
> 
> Consequently, when an error occurs during kernel booting, the kernel is
> unable to handle and report errors until the GHES driver is initialized by
> device_initcall(), in which the event callback is registered. All errors
> that occurred before GHES initialization are missed and there is no chance
> to report and find them again.
> 
> From commit e147133a42cb ("ACPI / APEI: Make hest.c manage the estatus
> memory pool") was merged, ghes_init() relies on acpi_hest_init() to manage
> the estatus memory pool. On the other hand, ghes_init() relies on
> sdei_init() to detect the SDEI version and the framework for registering
> and unregistering events.

> By the way, I don't figure out why acpi_hest_init is called in
> acpi_pci_root_init, it don't rely on any other thing. May it could
> be moved further, following acpi_iort_init in acpi_init.

I think you should drop the "By the way ..." text or move it after the
"---" at the bottom of your commit log.  It doesn't help understand
this patch.

> sdei_init() relies on ACPI table which is initialized
> subsys_initcall(): acpi_init(), acpi_bus_init(), acpi_load_tables(),
> acpi_tb_laod_namespace().  May it should be also moved further,
> after acpi_load_tables.

This text also doesn't seem relevant to this patch.

> In this patch, move sdei_init and ghes_init as far ahead as
> possible, right after acpi_hest_init().

I'm having a hard time figuring out the reason for this patch.

Apparently the relevant parts are sdei_init() and ghes_init().
Today they are executed in that order:

  subsys_initcall_sync(sdei_init);
  device_initcall(ghes_init);

After this patch, they would be executed in the same order, but called
explicitly instead of as initcalls:

  acpi_pci_root_init()
  {
    acpi_hest_init();
    sdei_init();
    ghes_init();
    ...

Explicit calls are certainly better than initcalls, but that doesn't
seem to be the reason for this patch.

Does this patch fix a bug?  If so, what is the bug?

You say that currently "errors that occur before GHES initialization
are missed".  Isn't that still true after this patch?  Does this patch
merely reduce the time before GHES initialization?  If so, I'm
dubious, because we have to tolerate an arbitrary amount of time
there.

s/acpi_tb_laod_namespace/acpi_tb_load_namespace/

You use "()" after function names sometimes, but not always.  Please
do it consistently.

> -device_initcall(ghes_init);

>  void __init acpi_pci_root_init(void)
>  {
>  	acpi_hest_init();
> +	sdei_init();
> +	ghes_init();

What's the connection between PCI, SDEI, and GHES?  As far as I can
tell, SDEI and GHES are not PCI-specific, so it doesn't seem like they
should be initialized here in acpi_pci_root_init().

> -subsys_initcall_sync(sdei_init);



More information about the linux-arm-kernel mailing list