[PATCH v2 28/34] kasan, vmalloc: add vmalloc support to HW_TAGS

Andrey Konovalov andreyknvl at gmail.com
Mon Dec 13 13:57:33 PST 2021


On Mon, Dec 13, 2021 at 4:34 PM Vincenzo Frascino
<vincenzo.frascino at arm.com> wrote:
>
> Hi Andrey,
>
> On 12/6/21 9:44 PM, andrey.konovalov at linux.dev wrote:
> > From: Andrey Konovalov <andreyknvl at google.com>
> >
> > This patch adds vmalloc tagging support to HW_TAGS KASAN.
> >
>
> Can we reorganize the patch description in line with what I commented on patch 24?

Hi Vincenzo,

Done in v3.

> >  void * __must_check __kasan_unpoison_vmalloc(const void *start,
> > -                                          unsigned long size);
> > +                                          unsigned long size,
> > +                                          bool vm_alloc, bool init);
> >  static __always_inline void * __must_check kasan_unpoison_vmalloc(
> > -                                     const void *start, unsigned long size)
> > +                                     const void *start, unsigned long size,
> > +                                     bool vm_alloc, bool init)
>
> Can we replace booleans with enumerations? It should make the code clearer on
> the calling site.

I think we can add a single argument for named flags to improve
readability. Done in v3.

> With these changes:
>
> Signed-off-by: Vincenzo Frascino <vincenzo.frascino at arm.com>

Thanks!



More information about the linux-arm-kernel mailing list