[PATCH 1/2] bus/fsl-mc: Add generic implementation for open/reset/close commands

Laurentiu Tudor laurentiu.tudor at nxp.com
Mon Aug 30 02:29:23 PDT 2021



On 8/25/2021 12:05 PM, Diana Craciun wrote:
> The open/reset/close commands format is similar for all objects.
> Currently there are multiple implementations for these commands
> scattered through various drivers. The code is cavsi-identical.
> Create a generic implementation for the open/reset/close commands.
> One of the consumer will be the VFIO driver which needs to
> be able to reset a device.
> 
> Signed-off-by: Diana Craciun <diana.craciun at oss.nxp.com>
> ---
>  drivers/bus/fsl-mc/Makefile         |   3 +-
>  drivers/bus/fsl-mc/fsl-mc-private.h |  39 +++++++++--
>  drivers/bus/fsl-mc/obj-api.c        | 104 ++++++++++++++++++++++++++++
>  include/linux/fsl/mc.h              |  14 ++++
>  4 files changed, 155 insertions(+), 5 deletions(-)
>  create mode 100644 drivers/bus/fsl-mc/obj-api.c
> 
> diff --git a/drivers/bus/fsl-mc/Makefile b/drivers/bus/fsl-mc/Makefile
> index 4ae292a30e53..892946245527 100644
> --- a/drivers/bus/fsl-mc/Makefile
> +++ b/drivers/bus/fsl-mc/Makefile
> @@ -15,7 +15,8 @@ mc-bus-driver-objs := fsl-mc-bus.o \
>  		      dprc-driver.o \
>  		      fsl-mc-allocator.o \
>  		      fsl-mc-msi.o \
> -		      dpmcp.o
> +		      dpmcp.o \
> +		      obj-api.o
>  
>  # MC userspace support
>  obj-$(CONFIG_FSL_MC_UAPI_SUPPORT) += fsl-mc-uapi.o
> diff --git a/drivers/bus/fsl-mc/fsl-mc-private.h b/drivers/bus/fsl-mc/fsl-mc-private.h
> index 1958fa065360..6055ef3e9e02 100644
> --- a/drivers/bus/fsl-mc/fsl-mc-private.h
> +++ b/drivers/bus/fsl-mc/fsl-mc-private.h
> @@ -48,7 +48,6 @@ struct dpmng_rsp_get_version {
>  
>  /* DPMCP command IDs */
>  #define DPMCP_CMDID_CLOSE		DPMCP_CMD(0x800)
> -#define DPMCP_CMDID_OPEN		DPMCP_CMD(0x80b)
>  #define DPMCP_CMDID_RESET		DPMCP_CMD(0x005)
>  
>  struct dpmcp_cmd_open {
> @@ -91,7 +90,6 @@ int dpmcp_reset(struct fsl_mc_io *mc_io,
>  
>  /* DPRC command IDs */
>  #define DPRC_CMDID_CLOSE                        DPRC_CMD(0x800)
> -#define DPRC_CMDID_OPEN                         DPRC_CMD(0x805)
>  #define DPRC_CMDID_GET_API_VERSION              DPRC_CMD(0xa05)
>  
>  #define DPRC_CMDID_GET_ATTR                     DPRC_CMD(0x004)
> @@ -453,7 +451,6 @@ int dprc_get_connection(struct fsl_mc_io *mc_io,
>  
>  /* Command IDs */
>  #define DPBP_CMDID_CLOSE		DPBP_CMD(0x800)
> -#define DPBP_CMDID_OPEN			DPBP_CMD(0x804)
>  
>  #define DPBP_CMDID_ENABLE		DPBP_CMD(0x002)
>  #define DPBP_CMDID_DISABLE		DPBP_CMD(0x003)
> @@ -492,7 +489,6 @@ struct dpbp_rsp_get_attributes {
>  
>  /* Command IDs */
>  #define DPCON_CMDID_CLOSE			DPCON_CMD(0x800)
> -#define DPCON_CMDID_OPEN			DPCON_CMD(0x808)
>  
>  #define DPCON_CMDID_ENABLE			DPCON_CMD(0x002)
>  #define DPCON_CMDID_DISABLE			DPCON_CMD(0x003)
> @@ -524,6 +520,41 @@ struct dpcon_cmd_set_notification {
>  	__le64 user_ctx;
>  };
>  
> +/*
> + * Generic FSL MC API
> + */
> +
> +/* generic command versioning */
> +#define OBJ_CMD_BASE_VERSION		1
> +#define OBJ_CMD_ID_OFFSET		4
> +
> +#define OBJ_CMD(id)	(((id) << OBJ_CMD_ID_OFFSET) | OBJ_CMD_BASE_VERSION)
> +
> +/* open command codes */
> +#define DPRTC_CMDID_OPEN		OBJ_CMD(0x810)
> +#define DPNI_CMDID_OPEN		OBJ_CMD(0x801)
> +#define DPSW_CMDID_OPEN		OBJ_CMD(0x802)
> +#define DPIO_CMDID_OPEN		OBJ_CMD(0x803)
> +#define DPBP_CMDID_OPEN		OBJ_CMD(0x804)
> +#define DPRC_CMDID_OPEN		OBJ_CMD(0x805)
> +#define DPDMUX_CMDID_OPEN		OBJ_CMD(0x806)
> +#define DPCI_CMDID_OPEN		OBJ_CMD(0x807)
> +#define DPCON_CMDID_OPEN		OBJ_CMD(0x808)
> +#define DPSECI_CMDID_OPEN		OBJ_CMD(0x809)
> +#define DPAIOP_CMDID_OPEN		OBJ_CMD(0x80a)
> +#define DPMCP_CMDID_OPEN		OBJ_CMD(0x80b)
> +#define DPMAC_CMDID_OPEN		OBJ_CMD(0x80c)
> +#define DPDCEI_CMDID_OPEN		OBJ_CMD(0x80d)
> +#define DPDMAI_CMDID_OPEN		OBJ_CMD(0x80e)
> +#define DPDBG_CMDID_OPEN		OBJ_CMD(0x80f)
> +
> +/* Generic object command IDs */
> +#define OBJ_CMDID_CLOSE		OBJ_CMD(0x800)
> +#define OBJ_CMDID_RESET		OBJ_CMD(0x005)
> +
> +struct obj_cmd_open {

Nit: maybe the name should be made less generic, e.g. fsl_mc_obj_cmd_open.

Otherwise, looks good to me:

Reviewed-by: Laurentiu Tudor <laurentiu.tudor at nxp.com>

---
Best Regards, Laurentiu



More information about the linux-arm-kernel mailing list