[PATCH 0/5] ARM: dts: rcar2: Configure pull up for GPIO keys
Geert Uytterhoeven
geert+renesas at glider.be
Fri Apr 30 14:10:50 BST 2021
Hi all,
This patches series follows up on the work started with "[PATCH] ARM:
dts: koelsch: Configure pull-up for SOFT_SW GPIO keys"[1], and
explicitly configures pull-ups for pins used for GPIO keys without
external pull-up resistors on R-Car Gen2 boards, preceded by a small
cleanup. Currently GPIO keys rely on the initial states of these pins,
which fortunately match the expectations, but it is better to be
explicit.
To actually make a difference, this depends on "[PATCH 00/12] pinctrl:
renesas: Add more bias pinconf support"[2]. Note that it is safe to
apply this series before [2] has landed, as pinctrl_bind_pins() does not
consider -ENOTSUPP a fatal error.
It would be great if people with access to the hardware could do similar
tests like I did on Koelsch[3].
I hope to queue this in renesas-devel for v5.14.
Thanks for your comments!
[1] https://lore.kernel.org/r/20210303132941.3938516-1-geert+renesas@glider.be/
[2] https://lore.kernel.org/r/cover.1619785375.git.geert+renesas@glider.be/
[3] https://lore.kernel.org/r/20210303132619.3938128-1-geert+renesas@glider.be
Geert Uytterhoeven (5):
ARM: dts: koelsch: Rename sw2 to keyboard
ARM: dts: lager: Configure pull-up for SOFT_SW GPIO keys
ARM: dts: blanche: Configure pull-up for SOFT_SW and SW25 GPIO keys
ARM: dts: gose: Configure pull-up for SOFT_SW GPIO keys
ARM: dts: silk: Configure pull-up for SOFT_SW GPIO keys
arch/arm/boot/dts/r8a7790-lager.dts | 8 ++++++++
arch/arm/boot/dts/r8a7791-koelsch.dts | 4 ++--
arch/arm/boot/dts/r8a7792-blanche.dts | 8 ++++++++
arch/arm/boot/dts/r8a7793-gose.dts | 10 +++++++++-
arch/arm/boot/dts/r8a7794-silk.dts | 10 +++++++++-
5 files changed, 36 insertions(+), 4 deletions(-)
--
2.25.1
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert at linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
More information about the linux-arm-kernel
mailing list