[PATCH 06/10] memory: tegra: Parameterize interrupt handler
Dmitry Osipenko
digetx at gmail.com
Thu Apr 22 00:33:25 BST 2021
20.04.2021 19:52, Thierry Reding пишет:
> +const char *const status_names[32] = {
> + [ 1] = "External interrupt",
> + [ 6] = "EMEM address decode error",
> + [ 7] = "GART page fault",
> + [ 8] = "Security violation",
> + [ 9] = "EMEM arbitration error",
> + [10] = "Page fault",
> + [11] = "Invalid APB ASID update",
> + [12] = "VPR violation",
> + [13] = "Secure carveout violation",
> + [16] = "MTS carveout violation",
> +};
>
> - return IRQ_HANDLED;
> -}
> +const char *const error_names[8] = {
> + [2] = "EMEM decode error",
> + [3] = "TrustZone violation",
> + [4] = "Carveout violation",
> + [6] = "SMMU translation error",
> +};
>
These struct names are too generic for a global names, what about
prefixing them with tegra_mc_ ?
More information about the linux-arm-kernel
mailing list