[RESEND PATCH v5 2/5] driver core: add deferring probe reason to devices_deferred property

Andrzej Hajda a.hajda at samsung.com
Wed Jun 24 09:28:34 EDT 2020


On 24.06.2020 14:11, Rafael J. Wysocki wrote:
> On Wed, Jun 24, 2020 at 1:41 PM Andrzej Hajda <a.hajda at samsung.com> wrote:
>> /sys/kernel/debug/devices_deferred property contains list of deferred devices.
>> This list does not contain reason why the driver deferred probe, the patch
>> improves it.
>> The natural place to set the reason is probe_err function introduced recently,
>> ie. if probe_err will be called with -EPROBE_DEFER instead of printk the message
>> will be attached to deferred device and printed when user read devices_deferred
>> property.
>>
>> Signed-off-by: Andrzej Hajda <a.hajda at samsung.com>
>> Reviewed-by: Mark Brown <broonie at kernel.org>
>> Reviewed-by: Javier Martinez Canillas <javierm at redhat.com>
>> Reviewed-by: Andy Shevchenko <andy.shevchenko at gmail.com>
>> ---
>>   drivers/base/base.h |  3 +++
>>   drivers/base/core.c | 10 ++++++----
>>   drivers/base/dd.c   | 21 ++++++++++++++++++++-
>>   3 files changed, 29 insertions(+), 5 deletions(-)
>>
>> diff --git a/drivers/base/base.h b/drivers/base/base.h
>> index 95c22c0f9036..93ef1c2f4c1f 100644
>> --- a/drivers/base/base.h
>> +++ b/drivers/base/base.h
>> @@ -93,6 +93,7 @@ struct device_private {
>>          struct klist_node knode_class;
>>          struct list_head deferred_probe;
>>          struct device_driver *async_driver;
>> +       char *deferred_probe_msg;
> What about calling this deferred_probe_reason?
>
>>          struct device *device;
>>          u8 dead:1;
>>   };
>> @@ -134,6 +135,8 @@ extern void device_release_driver_internal(struct device *dev,
>>   extern void driver_detach(struct device_driver *drv);
>>   extern int driver_probe_device(struct device_driver *drv, struct device *dev);
>>   extern void driver_deferred_probe_del(struct device *dev);
>> +extern void __deferred_probe_set_msg(const struct device *dev,
>> +                                    struct va_format *vaf);
> I'd call this device_set_deferred_probe_reson() to follow the naming
> convention for the function names in this header file.
>
>>   static inline int driver_match_device(struct device_driver *drv,
>>                                        struct device *dev)
>>   {
>> diff --git a/drivers/base/core.c b/drivers/base/core.c
>> index ee9da66bff1b..2a96954d5460 100644
>> --- a/drivers/base/core.c
>> +++ b/drivers/base/core.c
>> @@ -3962,6 +3962,8 @@ define_dev_printk_level(_dev_info, KERN_INFO);
>>    *
>>    * This helper implements common pattern present in probe functions for error
>>    * checking: print message if the error is not -EPROBE_DEFER and propagate it.
>> + * In case of -EPROBE_DEFER it sets defer probe reason, which can be checked
>> + * later by reading devices_deferred debugfs attribute.
>>    * It replaces code sequence:
>>    *     if (err != -EPROBE_DEFER)
>>    *             dev_err(dev, ...);
>> @@ -3977,14 +3979,14 @@ int probe_err(const struct device *dev, int err, const char *fmt, ...)
>>          struct va_format vaf;
>>          va_list args;
>>
>> -       if (err == -EPROBE_DEFER)
>> -               return err;
>> -
>>          va_start(args, fmt);
>>          vaf.fmt = fmt;
>>          vaf.va = &args;
>>
>> -       dev_err(dev, "error %d: %pV", err, &vaf);
>> +       if (err == -EPROBE_DEFER)
>> +               __deferred_probe_set_msg(dev, &vaf);
>> +       else
>> +               dev_err(dev, "error %d: %pV", err, &vaf);
>>
>>          va_end(args);
>>
>> diff --git a/drivers/base/dd.c b/drivers/base/dd.c
>> index 9a1d940342ac..f44d26454b6a 100644
>> --- a/drivers/base/dd.c
>> +++ b/drivers/base/dd.c
>> @@ -27,6 +27,7 @@
>>   #include <linux/async.h>
>>   #include <linux/pm_runtime.h>
>>   #include <linux/pinctrl/devinfo.h>
>> +#include <linux/slab.h>
>>
>>   #include "base.h"
>>   #include "power/power.h"
>> @@ -136,6 +137,8 @@ void driver_deferred_probe_del(struct device *dev)
>>          if (!list_empty(&dev->p->deferred_probe)) {
>>                  dev_dbg(dev, "Removed from deferred list\n");
>>                  list_del_init(&dev->p->deferred_probe);
>> +               kfree(dev->p->deferred_probe_msg);
>> +               dev->p->deferred_probe_msg = NULL;
>>          }
>>          mutex_unlock(&deferred_probe_mutex);
>>   }
>> @@ -211,6 +214,21 @@ void device_unblock_probing(void)
>>          driver_deferred_probe_trigger();
>>   }
>>
>> +/*
>> + * __deferred_probe_set_msg() - Set defer probe reason message for device
> I'd change this into a full kerneldoc comment.


OK I will apply all changes in next version. Thx for review.


Regards

Andrzej


>
>> + */
>> +void __deferred_probe_set_msg(const struct device *dev, struct va_format *vaf)
>> +{
>> +       const char *drv = dev_driver_string(dev);
>> +
>> +       mutex_lock(&deferred_probe_mutex);
>> +
>> +       kfree(dev->p->deferred_probe_msg);
>> +       dev->p->deferred_probe_msg = kasprintf(GFP_KERNEL, "%s: %pV", drv, vaf);
>> +
>> +       mutex_unlock(&deferred_probe_mutex);
>> +}
>> +
>>   /*
>>    * deferred_devs_show() - Show the devices in the deferred probe pending list.
>>    */
>> @@ -221,7 +239,8 @@ static int deferred_devs_show(struct seq_file *s, void *data)
>>          mutex_lock(&deferred_probe_mutex);
>>
>>          list_for_each_entry(curr, &deferred_probe_pending_list, deferred_probe)
>> -               seq_printf(s, "%s\n", dev_name(curr->device));
>> +               seq_printf(s, "%s\t%s", dev_name(curr->device),
>> +                          curr->device->p->deferred_probe_msg ?: "\n");
>>
>>          mutex_unlock(&deferred_probe_mutex);
>>
>> --
>> 2.17.1
>>
> _______________________________________________
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> https://protect2.fireeye.com/url?k=5adb7884-070fc5c0-5adaf3cb-0cc47a31381a-5588a624ab84213e&q=1&u=https%3A%2F%2Flists.freedesktop.org%2Fmailman%2Flistinfo%2Fdri-devel
>



More information about the linux-arm-kernel mailing list