[PATCH 2/2] hwrng: iproc-rng200: Move enable/disable in separate function
Florian Fainelli
f.fainelli at gmail.com
Mon Dec 14 12:39:01 EST 2020
On 12/14/20 8:04 AM, matthias.bgg at kernel.org wrote:
> From: Matthias Brugger <mbrugger at suse.com>
>
> We are calling the same code for enable and disable the block in various
> parts of the driver. Put that code into a new function to reduce code
> duplication.
>
> Signed-off-by: Matthias Brugger <mbrugger at suse.com>
>
> ---
>
> drivers/char/hw_random/iproc-rng200.c | 37 ++++++++++++---------------
> 1 file changed, 17 insertions(+), 20 deletions(-)
>
> diff --git a/drivers/char/hw_random/iproc-rng200.c b/drivers/char/hw_random/iproc-rng200.c
> index e106ce3c0146..3367b26085e8 100644
> --- a/drivers/char/hw_random/iproc-rng200.c
> +++ b/drivers/char/hw_random/iproc-rng200.c
> @@ -53,15 +53,26 @@ struct iproc_rng200_dev {
>
> #define to_rng_priv(rng) container_of(rng, struct iproc_rng200_dev, rng)
>
> -static void iproc_rng200_restart(void __iomem *rng_base)
> +static void iproc_rng200_enable(void __iomem *rng_base, bool enable)
I would prefer naming the function iproc_rng200_enable_set() to indicate
that it sets the enable to the parameter value, this is just personal
taste, you may discard it.
> {
> uint32_t val;
Since you are refactoring this into a new function, do you mind changing
the variable to u32 to match the kernel code? With that fixed:
Acked-by: Florian Fainelli <f.fainelli at gmail.com>
Thanks!
--
Florian
More information about the linux-arm-kernel
mailing list