[PATCH 03/13] drm/kms/mode/exynos-dsi: using helper func drm_display_mode_to_videomode for calculating timing parameters

Robin Murphy robin.murphy at arm.com
Thu May 3 05:21:33 PDT 2018


On 03/05/18 09:39, Satendra Singh Thakur wrote:
> To avoid duplicate logic for the same
> 
> Signed-off-by: Satendra Singh Thakur <satendra.t at samsung.com>
> Cc: Madhur Verma <madhur.verma at samsung.com>
> Cc: Hemanshu Srivastava <hemanshu.s at samsung.com>
> ---
>   drivers/gpu/drm/exynos/exynos_drm_dsi.c | 9 +--------
>   1 file changed, 1 insertion(+), 8 deletions(-)
> 
> diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c b/drivers/gpu/drm/exynos/exynos_drm_dsi.c
> index 7904ffa..9397e5c 100644
> --- a/drivers/gpu/drm/exynos/exynos_drm_dsi.c
> +++ b/drivers/gpu/drm/exynos/exynos_drm_dsi.c
> @@ -1493,14 +1493,7 @@ static void exynos_dsi_mode_set(struct drm_encoder *encoder,
>   	struct videomode *vm = &dsi->vm;
>   	struct drm_display_mode *m = adjusted_mode;

FWIW you could just pass &dsi->vm and adjusted_mode directly to the 
helper and get rid of these locals too.

Robin.

>   
> -	vm->hactive = m->hdisplay;
> -	vm->vactive = m->vdisplay;
> -	vm->vfront_porch = m->vsync_start - m->vdisplay;
> -	vm->vback_porch = m->vtotal - m->vsync_end;
> -	vm->vsync_len = m->vsync_end - m->vsync_start;
> -	vm->hfront_porch = m->hsync_start - m->hdisplay;
> -	vm->hback_porch = m->htotal - m->hsync_end;
> -	vm->hsync_len = m->hsync_end - m->hsync_start;
> +	drm_display_mode_to_videomode(m, vm);
>   }
>   
>   static const struct drm_encoder_helper_funcs exynos_dsi_encoder_helper_funcs = {
> 



More information about the linux-arm-kernel mailing list