[PATCH 2/3] dmaengine: qcom_hidma: add support for the new revision

Sinan Kaya okaya at codeaurora.org
Mon Nov 6 14:09:29 PST 2017


On 11/6/2017 1:15 PM, Sinan Kaya wrote:
> On 11/6/2017 1:03 PM, Robin Murphy wrote:
>>>  #ifdef CONFIG_ACPI
>>>  		ret = strcmp(acpi_device_hid(adev), "QCOM8062");
>>> +		if (ret)
>>> +			ret = strcmp(acpi_device_hid(adev), "QCOM8063");
>> This string-juggling looks to have already hit the point at which it
>> doesn't scale well - it would be a lot nicer to make use of
>> of_device_get_match_data() and the ACPI equivalent to abstract the
>> version-specific data appropriately.
> 
> Sure, let me do some research.
> 

I just wanted to double check here. 

This is what I can do:
1. Maintain different match tables for different driver capabilities.
2. Instead of doing open-coded strcmp, I can do match against different tables
using acpi_match_device/of_match_device.

Hope this works for you.

-- 
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the Code Aurora Forum, a Linux Foundation Collaborative Project.



More information about the linux-arm-kernel mailing list