[PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1

Borislav Petkov bp at alien8.de
Thu Apr 13 16:47:45 EDT 2017

On Thu, Apr 13, 2017 at 02:30:21PM -0600, Baicar, Tyler wrote:
> I do not agree with this. The struct being passed to this function is
> already named acpi_hest_generic_data in the existing code and all over this
> code is named gdata not just d.

And I'm saying they're too long - the preexisting ones and the ones
you're adding - and impair readability. This whole driver is one
unreadable ugly pile and if I were the maintainer I would never allowed
it in its current form.

But I don't think it really has a maintainer - poor Rafael has to deal
with it because it is under drivers/acpi/ and that whole RAS firmware
crap got thrown over the wall at some point and now we're stuck with it.

So this is just my opinion since he asked me to take a look.


Good mailing practices for 400: avoid top-posting and trim the reply.

More information about the linux-arm-kernel mailing list