[RFC PATCH 03/12] arm64: kvm: Cleanup VTCR_EL2/VTTBR computation
Suzuki K. Poulose
Suzuki.Poulose at arm.com
Wed Mar 16 08:37:18 PDT 2016
On 16/03/16 15:01, Marc Zyngier wrote:
> On 14/03/16 16:53, Suzuki K Poulose wrote:
>> No functional changes. Group the common bits for VCTR_EL2
>> initialisation for better readability. The granule size
>> and the entry level are controlled by the page size.
>>
>> diff --git a/arch/arm64/include/asm/kvm_arm.h b/arch/arm64/include/asm/kvm_arm.h
>> index b7d61e4..d49dd50 100644
>> --- a/arch/arm64/include/asm/kvm_arm.h
>> +++ b/arch/arm64/include/asm/kvm_arm.h
>> @@ -139,32 +139,30 @@
>> * The magic numbers used for VTTBR_X in this patch can be found in Tables
>> * D4-23 and D4-25 in ARM DDI 0487A.b.
>> */
...
>>
>> +#define VTCR_EL2_FLAGS (VTCR_EL2_TGRAN_FLAGS | VTCR_EL2_COMMON_BITS)
>> +#define VTTBR_X ((VTTBR_X_TGRAN_MAGIC) - VTCR_EL2_T0SZ_40B)
>
> Nit: spurious brackets.
Will remove them.
> It would be nice to add an ARMv8 ARM reference to where the "magic"
> value is coming from.
That reference already exists in the code, see above.
>
>> +
>> #define VTTBR_BADDR_SHIFT (VTTBR_X - 1)
>> #define VTTBR_BADDR_MASK (((UL(1) << (PHYS_MASK_SHIFT - VTTBR_X)) - 1) << VTTBR_BADDR_SHIFT)
>> #define VTTBR_VMID_SHIFT (UL(48))
>>
>
> Otherwise:
>
> Acked-by: Marc Zyngier <marc.zyngier at arm.com>
Thanks
Suzuki
More information about the linux-arm-kernel
mailing list