[PATCH V5 04/11] soc: mediatek: PMIC wrap: split SoC specific init into callback

John Crispin blogic at openwrt.org
Sun Feb 14 13:01:38 PST 2016



On 11/02/2016 12:54, Matthias Brugger wrote:
>> diff --git a/drivers/soc/mediatek/mtk-pmic-wrap.c
>> b/drivers/soc/mediatek/mtk-pmic-wrap.c
>> index b22b664..e3bbee5 100644
>> --- a/drivers/soc/mediatek/mtk-pmic-wrap.c
>> +++ b/drivers/soc/mediatek/mtk-pmic-wrap.c
>> @@ -372,6 +372,7 @@ struct pmic_wrapper_type {
>>       enum pwrap_type type;
>>       u32 arb_en_all;
>>       int (*init_reg_clock)(struct pmic_wrapper *wrp);
>> +    int (*init_special)(struct pmic_wrapper *wrp);
> 
> Nit:
> I wonder if we can find a better name for the callback, as init_special
> sounds quite generic to me.
> 
> Thanks,
> Matthias

Hi,

At first I considered enable_wrapper as the mt8135/8173 code seems to do
just that. however mt2701 does an init of the ADC. So how about using
init_soc_specific ?

	John



More information about the linux-arm-kernel mailing list