[PATCH v2 1/3] of/fdt: factor out assignment of initrd_start/initrd_end
Ard Biesheuvel
ard.biesheuvel at linaro.org
Fri Feb 12 00:08:12 PST 2016
On 11 February 2016 at 23:12, Arnd Bergmann <arnd at arndb.de> wrote:
> On Thursday 11 February 2016 17:48:00 Ard Biesheuvel wrote:
>>
>> #ifdef CONFIG_BLK_DEV_INITRD
>> +void __weak __early_init_dt_declare_initrd(unsigned long start,
>> + unsigned long end)
>> +{
>> + initrd_start = (unsigned long)__va(start);
>> + initrd_end = (unsigned long)__va(end);
>> + initrd_below_start_ok = 1;
>> +}
>> +
>>
>
> I find __weak functions particularly hard to follow, I think a Kconfig
> symbols or a function you can override by defining a macro in asm/memory.h
> would be nicer.
>
OK, that makes sense.
I will give Catalin a chance to comment before respinning, though.
More information about the linux-arm-kernel
mailing list