[PATCH v3 4/6] [media] c8sectpfe: Update binding to reset-gpios
Javier Martinez Canillas
javier at dowhile0.org
Tue Sep 1 02:16:05 PDT 2015
On Tue, Sep 1, 2015 at 11:09 AM, Lee Jones <lee.jones at linaro.org> wrote:
> On Tue, 01 Sep 2015, Javier Martinez Canillas wrote:
>> On Fri, Aug 28, 2015 at 7:52 PM, Peter Griffin <peter.griffin at linaro.org> wrote:
>> > gpio.txt documents that GPIO properties should be named
>> > "[<name>-]gpios", with <name> being the purpose of this
>> > GPIO for the device.
>> > This change has been done as one atomic commit.
>> > Signed-off-by: Peter Griffin <peter.griffin at linaro.org>
>> > Acked-by: Lee Jones <lee.jones at linaro.org>
>> > ---
>> > Documentation/devicetree/bindings/media/stih407-c8sectpfe.txt | 6 +++---
>> > arch/arm/boot/dts/stihxxx-b2120.dtsi | 4 ++--
>> > drivers/media/platform/sti/c8sectpfe/c8sectpfe-core.c | 2 +-
>> > 3 files changed, 6 insertions(+), 6 deletions(-)
>> > diff --git a/Documentation/devicetree/bindings/media/stih407-c8sectpfe.txt b/Documentation/devicetree/bindings/media/stih407-c8sectpfe.txt
>> > index d4def76..e70d840 100644
>> > --- a/Documentation/devicetree/bindings/media/stih407-c8sectpfe.txt
>> > +++ b/Documentation/devicetree/bindings/media/stih407-c8sectpfe.txt
>> > @@ -35,7 +35,7 @@ Required properties (tsin (child) node):
>> > - tsin-num : tsin id of the InputBlock (must be between 0 to 6)
>> > - i2c-bus : phandle to the I2C bus DT node which the demodulators & tuners on this tsin channel are connected.
>> > -- rst-gpio : reset gpio for this tsin channel.
>> > +- reset-gpios : reset gpio for this tsin channel.
>> The documentation is a bit outdated, the GPIO subsystem supports both
>> -gpio and -gpios, see commit:
>> dd34c37aa3e8 ("gpio: of: Allow -gpio suffix for property names")
>> So it makes sense to me to use -gpio instead of -gpios in this case
>> since is a single GPIO. Also rst is already a descriptive name since
>> that's how many datasheets name a reset pin. I'm not saying I'm
>> against this patch, just pointing out since the commit message is a
>> bit misleading.
> As I suggested this patch, I feel I must comment.
> My order of preference would be:
> This current patch is No2, so it's okay to stay IMHO.
If the property is being changed anyways, why not going with No1 then?
As I said, I'm not against the patch but I think the commit message
has to be reworded since implies that the problem is that the -gpio
sufix is being used instead of -gpios. But since both are supported by
the GPIO subsystem, the commit should mention that "reset" is more
clear and easier to read than "rst" or something along those lines.
BTW, I just posted a patch for the GPIO doc to mention that -gpio is
> Lee Jones
> Linaro STMicroelectronics Landing Team Lead
> Linaro.org │ Open source software for ARM SoCs
> Follow Linaro: Facebook | Twitter | Blog
More information about the linux-arm-kernel