[PATCH RESEND v2 3/4] ARM: BCM: Add SMP support for Broadcom NSP

Linus Walleij linus.walleij at linaro.org
Mon Nov 16 13:09:27 PST 2015

On Tue, Nov 10, 2015 at 5:21 PM, Kapil Hali <kapilh at broadcom.com> wrote:
> On 11/10/2015 7:59 AM, Florian Fainelli wrote:

>>> Also give it a sane name, bcm_sec_boot_address or so.
>>> "secondary_boot" sounds like a function you call to boot
>>> the second core.
>> Agree with that, there could be a better name which better reflects
>> this is a variable.
> As this change is consolidating SMP implementation, I kept the same
> name of the variable which was used in kona_smp.c so that the changes
> in the common code is minimal. Also, the fact that the change is part
> of up-streamed code, I didn't alter with the variable name. Shall I
> change it in the next patch?

Sure do it any way as long as the end result looks fine.
It was not a big issue anyways.

Linus Walleij

More information about the linux-arm-kernel mailing list