[RFC PATCH] EDAC: Cleanup atomic_scrub mess

Chris Metcalf cmetcalf at ezchip.com
Fri May 22 13:13:22 PDT 2015

On 05/21/2015 02:11 PM, Borislav Petkov wrote:
> From: Borislav Petkov<bp at suse.de>
> So first of all, this atomic_scrub() function's naming is bad. It looks
> like an atomic_t helper. Change it to edac_atomic_scrub().
> The bigger problem is that this function is arch-specific and every new
> arch which doesn't necessarily need that functionality still needs to
> define it, otherwise EDAC doesn't compile.
> So instead of doing that and including arch-specific headers, have each
> arch define an EDAC_ATOMIC_SCRUB symbol which can be used in edac_mc.c
> for ifdeffery. Much cleaner.
> We already are doing this with another symbol - EDAC_SUPPORT. This is
> also much cleaner than having CONFIG_EDAC explicitly depend on all the
> arches which need/have EDAC support and drivers.
> This way I can kill the useless edac.h header in tile too.
> Signed-off-by: Borislav Petkov<bp at suse.de>

Acked-by: Chris Metcalf <cmetcalf at ezchip.com> [for tile]

Chris Metcalf, EZChip Semiconductor

More information about the linux-arm-kernel mailing list