[PATCH v2 3/4] clk: add lpc18xx ccu clk driver

Michael Turquette mturquette at linaro.org
Tue May 12 15:32:41 PDT 2015


Quoting Joachim Eastwood (2015-04-27 14:38:12)
> +static int of_clk_get_parent_arg(struct device_node *np, int index)
> +{
> +       struct of_phandle_args clkspec;
> +       int rc;
> +
> +       if (index < 0)
> +               return -EINVAL;
> +
> +       rc = of_parse_phandle_with_args(np, "clocks", "#clock-cells", index,
> +                                       &clkspec);
> +       if (rc)
> +               return -EINVAL;
> +
> +       return clkspec.args_count ? clkspec.args[0] : -EINVAL;
> +}

Hi Joachim,

I'm not sure why you need this. I guess it is related to my question in
patch #2 about using clock-indices? Can you explain why this function is
required?

Anyways if returning the clock index is something that is really needed
then why not rename it to "of_clk_get_index" and put it in
drivers/clk/clk.c?

Thanks,
Mike



More information about the linux-arm-kernel mailing list