not syncing: Attempted to kill init! exitcode=0x00000004 ?

Masahiro Yamada yamada.masahiro at
Wed May 6 19:30:25 PDT 2015

Hi Shawn,
(Sorry for late reply, I's been a vacation in Japan.)

2015-05-06 17:56 GMT+09:00 Shawn Guo <shawn.guo at>:
> On Tue, May 5, 2015 at 7:54 PM, Shawn Guo <shawn.guo at> wrote:
>> On Tue, Apr 07, 2015 at 12:34:30PM +0900, Masahiro Yamada wrote:
>>> Hello experts,
>>> I hope this is the correct ML to ask this question.
>>> I am struggling to port Linux-4.0-rc7 onto my SoC/board,
>>> based on ARM cortex-A9 (single CPU), but the kernel fails to boot
>>> with the error:
>>> "not syncing: Attempted to kill init! exitcode=0x00000004"
>> Hi Masahiro,
>> Have you track it down to the cause?  I'm asking because I'm seeing the
>> same issue with v4.0 on a vendor single Cortex-A9 SoC.

Yes, I have already solved my problem.

In my case,

 - The interrupt number for the UART device was wrong.  Fixed it.
 - I regenerated the initramdisk with Buildroot

and then I could boot the kernel successfully.

Best Regards
Masahiro Yamada

More information about the linux-arm-kernel mailing list