[Xen-devel] [PATCH v2 4/8] xen: Use the correctly the Xen memory terminologies
Julien Grall
julien.grall at citrix.com
Thu Aug 6 04:00:30 PDT 2015
Hi,
On 04/08/15 19:12, Julien Grall wrote:
> diff --git a/include/xen/page.h b/include/xen/page.h
> index c5ed20b..e7e1425 100644
> --- a/include/xen/page.h
> +++ b/include/xen/page.h
> @@ -3,9 +3,9 @@
>
> #include <asm/xen/page.h>
>
> -static inline unsigned long page_to_mfn(struct page *page)
> +static inline unsigned long page_to_gfn(struct page *page)
> {
> - return pfn_to_mfn(page_to_pfn(page));
> + return pfn_to_gfn(page_to_pfn(page));
> }
I've just noticed that there is a function gfn_to_page used for KVM.
Maybe I should rename page_to_gfn to xen_page_to_gfn to avoid confusion
with KVM one?
Regards,
--
Julien Grall
More information about the linux-arm-kernel
mailing list