[PATCH] pinctrl: clean up after enable refactoring

Stephen Warren swarren at wwwdotorg.org
Wed Sep 3 08:02:46 PDT 2014

On 09/03/2014 05:05 AM, Linus Walleij wrote:
> commit 2243a87d90b42eb38bc281957df3e57c712b5e56
> "pinctrl: avoid duplicated calling enable_pinmux_setting for a pin"
> removed the .disable callback from the struct pinmux_ops,
> making the .enable() callback the only remaining callback.
> However .enable() is a bad name as it seems to imply that a
> muxing can also be disabled. Rename the callback to .set_mux()
> and also take this opportunity to clean out any remaining
> mentions of .disable() from the documentation.

Acked-by: Stephen Warren <swarren at nvidia.com>

More information about the linux-arm-kernel mailing list