[PATCH v3 1/2] of: Rename "poweroff-source" property to "system-power-controller"
romain.perier at gmail.com
Tue Nov 11 11:01:10 PST 2014
2014-11-11 16:01 GMT+01:00 Grant Likely <grant.likely at linaro.org>:
> So, to be a little pendantic, the 'ti,' prefix is basically just for
> backwards compatibility with the old binding, and that old binding is
> only used on palmas.c, tps65*.c and twl4030-power.c, correct?
No, the backward compatibility here is only useful for drivers which
used "ti,system-power-controller" in the past and recently switched to
the new property through the standard helper function. As most of the
dts were not updated to use the new property, previous patches broke
compatibility with "ti,system-power-controller" (this compat would be
reverted with this serie). Only one driver has this problem, it is
So, What you propose is that I should handle the old property directly
from tps65910, and keep the standard helper generic right ?
> We don't actually want a ti comparison in the generic code. Normally
> what you'd do here is have the fixup in the ti driver code, possibly
> with a ti specific helper for those 4 files.
> I'm not going to nak this patch and I know you need to get things cleaned
> up, but the static inline really should be reduced back to just checking
> only for "system-power-controller". The current mainline code does the
> right thing anyway, and it is a *tiny* amount of extra code in 4 drivers
>> #endif /* _LINUX_OF_H */
More information about the linux-arm-kernel