[PATCH] gpio: unmap gpio irqs properly

Linus Walleij linus.walleij at linaro.org
Mon Mar 31 02:58:30 EDT 2014


On Sat, Mar 29, 2014 at 5:27 PM, Alexandre Courbot <gnurou at gmail.com> wrote:
> On Sat, Mar 29, 2014 at 4:44 AM, Linus Walleij <linus.walleij at linaro.org> wrote:

>> +static void gpiochip_irq_unmap(struct irq_domain *d, unsigned int irq)
>> +{
>> +#ifdef CONFIG_ARM
>> +       set_irq_flags(irq, 0);
>> +#endif
>
> Just curious here, why is a special case needed for ARM? I would not
> expect architecture-specific code on gpiolib, but I'm sure you have
> your reasons for that.

This is open-coded like this in all ARM-applicable drivers so I'm
just refactoring really.

I don't really know why but I was under the impression that this
ARM-specific function exists because the IRQ implementations in
the different archs have never really converged.

Yours,
Linus Walleij



More information about the linux-arm-kernel mailing list