[PATCH V2 3/3] arm: mm: Switch back to L_PTE_WRITE
Catalin Marinas
catalin.marinas at arm.com
Wed Mar 26 07:00:30 EDT 2014
On Tue, Feb 25, 2014 at 11:38:54AM +0000, Steve Capper wrote:
> --- a/arch/arm/include/asm/pgtable-3level.h
> +++ b/arch/arm/include/asm/pgtable-3level.h
> @@ -86,6 +86,7 @@
> #define L_PTE_DIRTY (_AT(pteval_t, 1) << 55) /* unused */
> #define L_PTE_SPECIAL (_AT(pteval_t, 1) << 56) /* unused */
> #define L_PTE_NONE (_AT(pteval_t, 1) << 57) /* PROT_NONE */
> +#define L_PTE_WRITE (_AT(pteval_t, 1) << 58)
I think we could rename L_PTE_RDONLY just to PTE_RDONLY since it's a
hardware bit and only used by LPAE.
Otherwise:
Reviewed-by: Catalin Marinas <catalin.marinas at arm.com>
More information about the linux-arm-kernel
mailing list