[PATCHv4 4/7] hwspinlock/core: add common OF helpers
ohad at wizery.com
Fri Mar 14 04:58:45 EDT 2014
On Tue, Mar 4, 2014 at 7:38 PM, Suman Anna <s-anna at ti.com> wrote:
>>>> Do you have any objections to the return code convention change?
>>> Unless strictly needed, I prefer we don't switch to the ERR_PTR code
>>> convention, as it reduces code readability and increases chances of
>>> user bugs.
>>> In our case, switching to ERR_PTR and friends seems only to optimize a
>>> few error paths, and I'm not sure it's a big win over simplicity.
>> When introducing the ability to reference a hwspin lock via a phandle
>> in device tree it makes a big difference to be able to differ between
>> the case of "initialization failed" or "device not yet probed"; so
>> that the client knows if it should fail or retry later.
> Can you confirm the changes you want me to make, so that I can refresh and
> post a v5 for 3.15?
Sorry, I missed your replies for some reason.
I prefer we stick with the current error handling code because I find
the alternative inferior (as long as it's not strictly needed).
More information about the linux-arm-kernel