[PATCH 2/3] ARM: at91: at91sam9g45: change at91_adc name
Alexandre Belloni
alexandre.belloni at free-electrons.com
Wed Mar 5 11:57:54 EST 2014
We can't use "at91_adc" to refer to the at91_adc driver anymore as the name is
used to match an id_table.
Signed-off-by: Alexandre Belloni <alexandre.belloni at free-electrons.com>
---
arch/arm/mach-at91/at91sam9g45_devices.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/mach-at91/at91sam9g45_devices.c b/arch/arm/mach-at91/at91sam9g45_devices.c
index cb36fa872d30..88554024eb2d 100644
--- a/arch/arm/mach-at91/at91sam9g45_devices.c
+++ b/arch/arm/mach-at91/at91sam9g45_devices.c
@@ -1203,7 +1203,7 @@ static struct resource adc_resources[] = {
};
static struct platform_device at91_adc_device = {
- .name = "at91_adc",
+ .name = "at91sam9g45-adc",
.id = -1,
.dev = {
.platform_data = &adc_data,
--
1.8.3.2
More information about the linux-arm-kernel
mailing list