[PATCH RFC 01/10] ARM: s3c64xx: pm: Use name field of generic_pm_domain

Tomasz Figa tomasz.figa at gmail.com
Sun Jan 12 14:03:50 EST 2014

On 12.01.2014 19:53, Pavel Machek wrote:
> Hi!
>>> Could we get some more descriptive names for the domains?
>> They are listed like this in user's manual, e.g. DOMAIN_F, DOMAIN_I,
>> DOMAIN_G, etc.
> I guessed so. So the manual sucks. Would it be feasible to get it more
> descriptive (like "Domain_G (GPU)")?

Does the name really matter that much? I changed original ones in this 
patch simply to make it easier to grep for domain related messages in 
kernel output (e.g. dmesg | grep domain). It was not the main part of 
this patch.

Also, there are multiple devices in most domains, so that would rather 
end up being "Domain_I (JPEG, Cam I/F)", "Domain_P (2D, TV Enc., 
Scaler)", "Domain_F (Rot, Post, LCD)".

If you really insist, I can change this, but I fail to see what effect 
it would really have.

Best regards,

More information about the linux-arm-kernel mailing list