socfpga mmc (was Re: [GIT PULL] SOCFPGA DTS updates for 3.17)

Pavel Machek pavel at
Thu Aug 14 11:47:12 PDT 2014


I tried booting kernel based on ba36899, and got:

mmc0: new SDHC card at address b368                                             
mmcblk0: mmc0:b368 USD   7.45 GiB                                               
 mmcblk0: p1 p2 p3 p4                                                           
VFS: Cannot open root device "mmcblk0p2" or unknown-block(0,0): error
Please append a correct "root=" boot option; here are the available
b300         7822336 mmcblk0  driver: mmcblk                                    
  b301          102400 mmcblk0p1 00082434-01                                    
  b302         1048576 mmcblk0p2 00082434-02                                    
  b303            1024 mmcblk0p3 00082434-03                                    
  b304         6086656 mmcblk0p4 00082434-04                                    
Kernel panic - not syncing: VFS: Unable to mount root fs on
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.16.0-11208-gef74117-dirty

IIRC it worked ok in 3.16 in similar config. It may be stupid mistake,
but if you know what I did wrong, I'd like to know... (-6 is ENXIO, so
-- how can the device be there and not be there at the same time?)

(cesky, pictures)

More information about the linux-arm-kernel mailing list