[PATCH 01/10] pwm-backlight: Refactor backlight power on/off
swarren at wwwdotorg.org
Tue Oct 1 14:26:07 EDT 2013
On 09/23/2013 03:40 PM, Thierry Reding wrote:
> In preparation for adding an optional regulator and enable GPIO to the
> driver, split the power on and power off sequences into separate
> functions to reduce code duplication at the multiple call sites.
> diff --git a/drivers/video/backlight/pwm_bl.c b/drivers/video/backlight/pwm_bl.c
> +static void pwm_backlight_power_off(struct pwm_bl_data *pb)
> + pwm_disable(pb->pwm);
Both the call-sites you're replacing do the following before pwm_disable():
pwm_config(pb->pwm, 0, pb->period);
While I agree that probably shouldn't be necessary, I think it's at
least worth mentioning that in the commit description just to make it
obvious that it was a deliberate change. Splitting that change into a
separate patch might be reasonable in order to keep refactoring and
functional changes separate, although perhaps it's not worth it.
There are also a couple unrelated whitespace changes thrown in here.
More information about the linux-arm-kernel