[PATCH] ARM: OMAP3: Beagle: Fix USB Host on beagle xM Ax/Bx

Roger Quadros rogerq at ti.com
Thu Jul 11 06:24:19 EDT 2013

On 07/09/2013 05:16 PM, Stefan Roese wrote:
> Hi Roger,
>> I have been too lazy to setup NFS :). But I will give it a shot soon to see what's going
>> wrong.
> Really appreciated. :) Please let me know if you need anything else from
> me to reproduce this issue.


I tried it out today and it worked 5/5 times. I used a bare bones debian root filesystem for
the NFS root.

Could it be possible that the boot scripts on your filesystem are somehow shutting down
the ethernet interface? Might be worth checking on a fresh filesystem.

My u-boot script is below and boot log is attached.

setenv bootargs console=ttyO2,115200n8 root=/dev/nfs rw nfsroot= ip= rootwait

setenv usbethaddr A6:66:4D:B0:69:04
setenv netmask
setenv ipaddr
setenv serverip

usb start

tftpboot 0x825f0000 omap3-beagle.dtb
tftpboot 0x80300000 uImage
set fdt_high 0xffffffff

bootm 0x80300000 - 0x825f0000


-------------- next part --------------
A non-text attachment was scrubbed...
Name: nfs-boot.log
Type: text/x-log
Size: 19655 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-arm-kernel/attachments/20130711/dc853f1d/attachment-0001.bin>

More information about the linux-arm-kernel mailing list