[PATCH v2 1/3] pwm: Add pwm_cansleep() as exported API to users
Florian Vaussard
florian.vaussard at epfl.ch
Mon Jan 28 04:36:07 EST 2013
Hello,
Le 28/01/2013 09:45, Peter Ujfalusi a écrit :
> hi Thierry,
>
> On 01/26/2013 06:40 AM, Thierry Reding wrote:
>>> + * @pwm: PWM device
>>> + *
>>> + * It returns nonzero if accessing the PWM can sleep.
>>> + */
>>> +int pwm_cansleep(struct pwm_device *pwm)
>>
>> I actually liked pwm_can_sleep() better. I find it to be more consistent
>> with the naming of other function names. It would furthermore match the
>> field name.
>
> I was looking at the GPIO API to suggest this name change, but you are right
> we should be consistent with the PWM API here.
> Sorry Florian.
>
No problem, I agree with the PWM API consistency.
>>
>>> +{
>>> + return pwm->chip->can_sleep;
>>> +}
>>> +EXPORT_SYMBOL_GPL(pwm_cansleep);
>>
>> Would it make sense to check for NULL pointers here? I guess that
>> passing NULL into the function could be considered a programming error
>> and an oops would be okay, but in that case there's no point in making
>> the function return an int. Also see my next comment.
>
> While it is unlikely to happen it is better to be safe, something like this
> will do:
>
> return pwm ? pwm->chip->can_sleep : 0;
>
Ok. And what about:
BUG_ON(pwm == NULL);
return pwm->chip->can_sleep;
>>
>>> +
>>> #ifdef CONFIG_DEBUG_FS
>>> static void pwm_dbg_show(struct pwm_chip *chip, struct seq_file *s)
>>> {
>>> diff --git a/include/linux/pwm.h b/include/linux/pwm.h
>>> index 70655a2..e2cb5c7 100644
>>> --- a/include/linux/pwm.h
>>> +++ b/include/linux/pwm.h
>>> @@ -146,6 +146,8 @@ struct pwm_ops {
>>> * @base: number of first PWM controlled by this chip
>>> * @npwm: number of PWMs controlled by this chip
>>> * @pwms: array of PWM devices allocated by the framework
>>> + * @can_sleep: flag must be set iff config()/enable()/disable() methods sleep,
>>> + * as they must while accessing PWM chips over I2C or SPI
>>> */
>>> struct pwm_chip {
>>> struct device *dev;
>>> @@ -159,6 +161,7 @@ struct pwm_chip {
>>> struct pwm_device * (*of_xlate)(struct pwm_chip *pc,
>>> const struct of_phandle_args *args);
>>> unsigned int of_pwm_n_cells;
>>> + unsigned int can_sleep:1;
>>
>> What's the reason for making this a bitfield? Couldn't we just use a
>> bool instead?
>
> I have also overlooked this. In my version I had the can_sleep as bool also.
>
Ok for a bool.
Thank you for your reviews. I will send a v3 sometimes today.
Cheers,
Florian
More information about the linux-arm-kernel
mailing list