[PATCH 04/17] Rename memory allocation/free functions
Matt Fleming
matt at console-pimps.org
Wed Aug 7 09:09:06 EDT 2013
On Tue, 06 Aug, at 08:45:00PM, Roy Franz wrote:
> Rename them to be more similar, as low_free() could be used to free
> memory allocated by both high_alloc() and low_alloc().
> high_alloc() -> efi_high_alloc()
> low_alloc() -> efi_low_alloc()
> low_free() -> efi_free()
>
> Signed-off-by: Roy Franz <roy.franz at linaro.org>
> ---
> arch/x86/boot/compressed/eboot.c | 19 ++++++++++---------
> drivers/firmware/efi/efi-stub-helper.c | 16 ++++++++--------
> 2 files changed, 18 insertions(+), 17 deletions(-)
[...]
> @@ -163,10 +163,10 @@ fail:
> }
>
> /*
> - * Allocate at the lowest possible address.
> + * Allocate at the lowest possible address, that is not below 'min'
> */
> -static efi_status_t low_alloc(efi_system_table_t *sys_table_arg,
> - unsigned long size, unsigned long align,
> +static efi_status_t efi_low_alloc(efi_system_table_t *sys_table_arg,
> + unsigned long size, unsigned long align,
> unsigned long *addr)
> {
> unsigned long map_size, desc_size;
Whoops, did this change to the comment slip in from some other patch?
--
Matt Fleming, Intel Open Source Technology Center
More information about the linux-arm-kernel
mailing list