[PATCH v3 1/5] drivers: memory: Introduce Marvell EBU Device Bus driver

Arnd Bergmann arnd at arndb.de
Sat Apr 6 09:05:33 EDT 2013


On Saturday 06 April 2013, Ezequiel Garcia wrote:

> + - devbus,dev-width:    0x0 = 8-bit
> +                        0x1 = 16-bit
> +                        0x2 = 32-bit
> +                        0x3 = Reserved

I think by convention this should be called "bus-width" and allow the
values <8>, <16> and <32>, each referrring to the width in bits.

> +/* Perhaps it makes sense to unify both compatible strins? */
> +static const struct of_device_id mvebu_devbus_of_match[] = {
> +	{ .compatible = "marvell,armada370-devbus"	 },
> +	{ .compatible = "marvell,armadaxp-devbus"	 },
> +	{},
> +};
> +MODULE_DEVICE_TABLE(of, mvebu_devbus_of_match);

Yes, if the hardware behaves identically and all the differences are
described in the other properties, just name it after the first soc
that had this devbus.

	Arnd



More information about the linux-arm-kernel mailing list