[PATCH v4 1/4] dt: add of_get_child_count helper function

Stephen Warren swarren at wwwdotorg.org
Thu Apr 26 12:24:11 EDT 2012


On 04/26/2012 08:40 AM, Dong Aisheng wrote:
> From: Dong Aisheng <dong.aisheng at linaro.org>
> 
> Currently most code to get child count in kernel are almost same,
> add a helper to implement this function for dt to use.

> diff --git a/include/linux/of.h b/include/linux/of.h

> +static inline int of_get_child_count(const struct device_node *np)
> +{
> +	struct device_node *child = NULL;

You don't actually need to initialize child here. It doesn't really
matter here, but in a more complex function, it might hide a
used-before-initialized error.



More information about the linux-arm-kernel mailing list