[PATCH 2/2] serial: msm: Add support for UARTDM cores
davidb at codeaurora.org
Wed Jan 19 14:52:02 EST 2011
On Wed, Jan 19 2011, Jamie Iles wrote:
> On Wed, Jan 19, 2011 at 09:31:55AM -0800, David Brown wrote:
>> I'm not sure what would be a better name for the flag, though. The
>> block is called UARTDM.
> Ok, it was mainly out of curiosity. I guess it could be 'use_dma' or
> perhaps a comment to explain what DM is but my curiosity is now
> satisfied ;-)
I think use_dma would probably be even more confusing, since it isn't
It's a flag indicating if the device has the capability of doing dma.
It's really a block version indicator, except that the blocks weren't
given different versions, but instead given a name based on the DMA.
I wonder if is_dma_capable would be better.
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.
More information about the linux-arm-kernel