camera on Freescale i.MX51

Claudiu Covaci claudiu.covaci at
Tue Jan 18 08:33:30 EST 2011


I'm have trouble receiving a video stream on the Freescale i.MX51
processor. I've tried everything I could think, so I'm trying my luck

I'm using a 2.6.31 kernel with some modifications: the camera capture
driver [1] and the IPU (Image Processing Unit) driver [2] from the
Freescale BSP 2010.11.

I'm at a point where I can open the /dev/video0 device and can (at
least try to) read frames, but it fails at dequeueing the video
buffers (VIDIOC_DQBUF) with the message:
<3>ERROR: v4l2 capture: mxc_v4l_dqueue timeout enc_counter 0
Unable to dequeue buffer (62).

- I've double-checked the IPU registers and they seem properly
configured, but I don't get any interrupt (at end-of-frame).
- The relevant IOMUX pins are also configured.
- the video signal appears at the i.MX pins (so it gets there)
- I've also tried activating the internal picture generator, but still
nothing happens.

Is there anything I overlooked? Is there a way to find out where the
problem is? Any hints will be greatly appreciated.




More information about the linux-arm-kernel mailing list