[PATCH] arch/arm: Use constants instead of magic numbers in do_gettimeofday.

Corbin Simpson mostawesomedude at gmail.com
Fri May 7 08:01:37 EDT 2010


On Wed, May 5, 2010 at 6:22 PM, Ben Dooks <ben-linux at fluff.org> wrote:
> On Wed, May 05, 2010 at 06:19:52PM -0700, Corbin Simpson wrote:
>> Part of the Didj patch.
>
> how about a better description here please.
>
>> Signed-off-by: Corbin Simpson <MostAwesomeDude at gmail.com>
>> ---
>>  arch/arm/kernel/time.c |    6 +++---
>>  1 files changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/arch/arm/kernel/time.c b/arch/arm/kernel/time.c
>> index 2875380..5cb4ff9 100644
>> --- a/arch/arm/kernel/time.c
>> +++ b/arch/arm/kernel/time.c
>> @@ -104,12 +104,12 @@ void do_gettimeofday(struct timeval *tv)
>>               seq = read_seqbegin_irqsave(&xtime_lock, flags);
>>               usec = system_timer->offset();
>>               sec = xtime.tv_sec;
>> -             usec += xtime.tv_nsec / 1000;
>> +             usec += xtime.tv_nsec / NSEC_PER_USEC;
>>       } while (read_seqretry_irqrestore(&xtime_lock, seq, flags));
>>
>>       /* usec may have gone up a lot: be safe */
>> -     while (usec >= 1000000) {
>> -             usec -= 1000000;
>> +     while (usec >=  USEC_PER_SEC) {
>> +             usec -= USEC_PER_SEC;
>>               sec++;
>>       }
>>
>> --
>> 1.6.6.1

Sorry, been out with a bad cold. :C

What would be better? It's a fairly trivial patch that is, at least in
my mind, fully explained by the title of the commit. Constants should
be preferred to magic numbers, right? The patch comment is a reminder
that this comes from the Leapfrog Didj code dump, and the original
author is unknown, but probably works at Cozybits.

Would this work?

Prefer constants to magic numbers where applicable and appropriate.
With this change, the code is almost self-explanatory and much more
readable.
Part of the Leapfrog Didj code dump. Authorship is unknown.

~ C.

-- 
When the facts change, I change my mind. What do you do, sir? ~ Keynes

Corbin Simpson
<MostAwesomeDude at gmail.com>



More information about the linux-arm-kernel mailing list