[PATCH 1/2] arm: Replace CONFIG_HAS_TLS_REG with HWCAP_TLS and check for it on V6
Tony Lindgren
tony at atomide.com
Fri Jul 2 06:37:46 EDT 2010
* Nicolas Pitre <nico at fluxnic.net> [100702 05:31]:
> On Thu, 1 Jul 2010, Jamie Lokier wrote:
>
> > Tony Lindgren wrote:
> > > +static void __init kuser_get_tls_init(unsigned long vectors)
> > > +{
> > > + /*
> > > + * vectors + 0xfe0 = __kuser_get_tls
> > > + * vectors + 0xfe8 = hardware TLS instruction at 0xffff0fe8
> > > + */
> > > + if (tls_emu || has_tls)
> > > + memcpy((void *)vectors + 0xfe0, (void *)vectors + 0xfe8, 4);
> > > +}
> >
> > Just a little opinion: Perhaps has_tls_reg would be a clearer name.
> > All variants "have TLS" after all.
>
> Good point.
I like that too. Updated patch below.
Tony
-------------- next part --------------
A non-text attachment was scrubbed...
Name: arm-tls-v7.patch
Type: text/x-diff
Size: 8749 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-arm-kernel/attachments/20100702/39043301/attachment.bin>
More information about the linux-arm-kernel
mailing list