[patch-v2.6.34 7/9] usb: musb: use only clk framework for clk handling

Felipe Balbi me at felipebalbi.com
Wed Dec 30 08:20:20 EST 2009


Hi,

adding Russell to Cc list as he might have comments.

On Wed, 2009-12-30 at 15:14 +0200, Felipe Balbi wrote:
> Hi,
> 
> On Wed, 2009-12-30 at 16:06 +0300, Sergei Shtylyov wrote:
> > Hello.
> > 
> > Felipe Balbi wrote:
> > 
> > >>    Why always "ick"?! Do you think OMAPs are the only boards using MUSB 
> > >> out there?
> > >>     
> > >
> > > err, I'm afraid you have to read more about clock framework. The clock
> > > name should not matter when you issue clk_get().
> > 
> >    It depends on the matching type determined from a clkdev matching 
> > table -- see dm644x_clks[] in arch/mach-davinci/dm644x.c as an example: 
> > 'struct davinci_clk' incorporates 'struct clk_lookup', and where its 1st 
> > member is initialized, the matching is done by device, where its second 
> > member is initialized, the matching is done by clock name -- see 
> > clk_find() in arch/arm/common/clkdev.c for the logic.
> 
> diff --git a/arch/arm/mach-davinci/dm644x.c
> b/arch/arm/mach-davinci/dm644x.c
> index 2cd0081..a0ad7b6 100644
> --- a/arch/arm/mach-davinci/dm644x.c
> +++ b/arch/arm/mach-davinci/dm644x.c
> @@ -306,7 +306,7 @@ struct davinci_clk dm644x_clks[] = {
>         CLK("davinci_mmc.0", NULL, &mmcsd_clk),
>         CLK(NULL, "spi", &spi_clk),
>         CLK(NULL, "gpio", &gpio_clk),
> -       CLK(NULL, "usb", &usb_clk),
> +       CLK("musb_hdrc", "usb", &usb_clk),
>         CLK(NULL, "vlynq", &vlynq_clk),
>         CLK(NULL, "aemif", &aemif_clk),
>         CLK(NULL, "pwm0", &pwm0_clk),
> 
> 
> there you are...

and the point is that we want to stop passing clock names down to the
driver so either we agree on using a generic name like "ick" or "usb",
or the clockdev implementation for that particular clock will match
device id. We sure need to think about clocks used by several devices,
we want to keep device id NULL, for sure.

Russell, how should we tackle this ?

-- 
balbi




More information about the linux-arm-kernel mailing list